SparkGIS Installation

Environment Variables

Please add or reconfigure your environment variables to have the following variables set up and pointing to correct paths (preferably in your ~/.bashrc file):

  • SPGIS_INC_PATH : This should be pointing to the include folder having header files for native functions. (Available when you download SparkGIS)
  • SPGIS_LIB_PATH: This should be pointing to the lib folder having compiled shared object libraries for native functions. (Available when you download SparkGIS)
  • SPARK_HOME: This should be pointing to your Apache Spark installation directory

Library Requirements and Dependencies

Below are the list of dependencies that SparkGIS requires. They must be available on or be accessible from all compute (task) nodes. You can install dependencies as the root user or a non-admin user.

Install the libraries in the following order:

  • g++ 4.x (x >= 4)
  • GEOS 3.x (x >= 3)
  • libspatialindex 1.8.x (x >= 0)
  • Maven 3.2.x (Compiling from source)

If you download from the provided link, the libraries are already compiled and available in the lib folder.

No additional installation is required. SparkGIS binary is available as a JAR which can be included in your project. The JAR can be downloaded through the Download page or can be added through maven (TBU).

Maven Repo: TBU